Rivian Forum – Rivian R1T & R1S News, Pricing & Order... banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Bringing my questions to the experts, and I have a lot of them. Can I start by saying that I love the truck, am an unabashed lemming that would follow RJ over a cliff, and won't be getting rid of the truck anytime soon. Just don't tell them that please. After a bumpy start with a still-not-yet-really-understood issue with a BCM that vanished after I did a 100% charge (my idea, not theirs), it's been a smooth experience. My tonneau even works! But...

1. I thought I might have an alignment issue, and have not taken the truck off road or even over a curb, but now I'm not sure it's not something bigger. I noticed that my wheel looks slightly off-centered, as others have reported, probably by 5ish degrees. When held straight, the truck will pull to the left, consistent with the wheel being off to the right when keeping the vehicle straight. What I noticed, though is that the gap on the driver side of the steering column, below the display, is large enough for my smallest fingertip to fit, but the opposite side is not. And when looked at closely, it looks like the column is slightly off center. Anyone else notice this/have this/willing to check if that's the case for theirs?

2. I can't quite tell if maybe my hood isn't somehow damaged or out of alignment. It looks to me as if the corners near the headlights are excessively curved in. I thought it might be the hood needed adjusted and pulled towards the front of the vehicle, but actually the hood edges closest to the windshield look perfectly aligned with the fender lines.

3. My charging door is a little out of perfect center/flush. It's not severe but its definitely noticeable. Anyone have experience with having it adjusted?

4. How long have people waited to get their full size spare that wasn't installed at delivery?

5. Anyone else got a weird little bump/pinch on their interior trim by a window?

6. My drivers seat trim on the drivers side is separating it seems. It doesn't look broken anywhere though. Anyone else?

7. And lastly...noises. Biggest issue is a recent clicking sound from under the truck when I push the pedal, and when I come off the pedal. My assumption is it has something to do with the motor reversing, but given it wasn't there to start, it's bugging me. And it's really annoying. I've also got a couple small rattles that have me worried only because the mileage is relatively low and it's summer. Anyone else feel like they're getting noises quickly?

Nothing service can't address I'm sure, but it'd be helpful to know what others' experiences have been so I have an idea what is reasonable to expect.
Grille Automotive lighting Hood Motor vehicle Automotive tire
Automotive parking light Grille Car Automotive lighting Hood
Automotive parking light Hood Automotive lighting Amber Vehicle
Car Plant Vehicle Automotive side-view mirror Automotive mirror
Grille Automotive lighting Hood Motor vehicle Automotive tire

Car Plant Vehicle Automotive side-view mirror Automotive mirror

Automotive parking light Hood Automotive lighting Amber Vehicle

Automotive parking light Grille Car Automotive lighting Hood
 

·
Registered
Joined
·
39 Posts
"... I'd say that's just the way it is"... But it shouldn't be and no it's not normal - have them look at it. What's it cost - nothing. And then peace of mind.For ref mine looks way better than the 1 picture you posted.

"Your seat is fine, too..." Agreed - Munro reported on it in one of their videos.

Your noise could be the "Tock" noise others have reported and what I have on all wheels. Awaiting service on it.

Interior trim - mines not like that.

As for column I'll look.
 

·
Registered
Joined
·
4 Posts
Bringing my questions to the experts, and I have a lot of them. Can I start by saying that I love the truck, am an unabashed lemming that would follow RJ over a cliff, and won't be getting rid of the truck anytime soon. Just don't tell them that please. After a bumpy start with a still-not-yet-really-understood issue with a BCM that vanished after I did a 100% charge (my idea, not theirs), it's been a smooth experience. My tonneau even works! But...

1. I thought I might have an alignment issue, and have not taken the truck off road or even over a curb, but now I'm not sure it's not something bigger. I noticed that my wheel looks slightly off-centered, as others have reported, probably by 5ish degrees. When held straight, the truck will pull to the left, consistent with the wheel being off to the right when keeping the vehicle straight. What I noticed, though is that the gap on the driver side of the steering column, below the display, is large enough for my smallest fingertip to fit, but the opposite side is not. And when looked at closely, it looks like the column is slightly off center. Anyone else notice this/have this/willing to check if that's the case for theirs?

2. I can't quite tell if maybe my hood isn't somehow damaged or out of alignment. It looks to me as if the corners near the headlights are excessively curved in. I thought it might be the hood needed adjusted and pulled towards the front of the vehicle, but actually the hood edges closest to the windshield look perfectly aligned with the fender lines.

3. My charging door is a little out of perfect center/flush. It's not severe but its definitely noticeable. Anyone have experience with having it adjusted?

4. How long have people waited to get their full size spare that wasn't installed at delivery?

5. Anyone else got a weird little bump/pinch on their interior trim by a window?

6. My drivers seat trim on the drivers side is separating it seems. It doesn't look broken anywhere though. Anyone else?

7. And lastly...noises. Biggest issue is a recent clicking sound from under the truck when I push the pedal, and when I come off the pedal. My assumption is it has something to do with the motor reversing, but given it wasn't there to start, it's bugging me. And it's really annoying. I've also got a couple small rattles that have me worried only because the mileage is relatively low and it's summer. Anyone else feel like they're getting noises quickly?

Nothing service can't address I'm sure, but it'd be helpful to know what others' experiences have been so I have an idea what is reasonable to expect. View attachment 7695 View attachment 7692 View attachment 7693 View attachment 7694 View attachment 7695
View attachment 7694
View attachment 7693
View attachment 7692
Dump it
 

·
Registered
From Tesla X to Rivian R1T, and not looking back!
Joined
·
16 Posts
If nothing else, get it documented and have service take a look. I just got mine back from a 36-hour service visit.

The hood: Mine is the same. Never really noticed, so I missed having service take a look.

Charge port door: mine was close to rubbing, so service adjusted it.

Spare tire: had mine installed 3 weeks after delivery. (22” bright)

Rattles: I was getting a rattle at the drivers door, so service removed the upper panel and re-torqued the bolts to the door panel.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
"... I'd say that's just the way it is"... But it shouldn't be and no it's not normal - have them look at it. What's it cost - nothing. And then peace of mind.For ref mine looks way better than the 1 picture you posted.

"Your seat is fine, too..." Agreed - Munro reported on it in one of their videos.

Your noise could be the "Tock" noise others have reported and what I have on all wheels. Awaiting service on it.

Interior trim - mines not like that.

As for column I'll look.
Thanks! Yeah, I'll mention all of these (but the seat) to service. I have a significant issue (bad rearview camera) that needs resolved, so I figure I'll lump all this in.
 

·
Registered
Joined
·
2 Posts
I haven't seen a single R1T where the hood lines up near the fender/headlight... I'd say that's just the way it is.

Your seat is fine, too. Rivian did things differently and moves the side plastic with the cushion. To confirm, you can adjust the seat cushion all the way down and now the panels will line up again.
Bringing my questions to the experts, and I have a lot of them. Can I start by saying that I love the truck, am an unabashed lemming that would follow RJ over a cliff, and won't be getting rid of the truck anytime soon. Just don't tell them that please. After a bumpy start with a still-not-yet-really-understood issue with a BCM that vanished after I did a 100% charge (my idea, not theirs), it's been a smooth experience. My tonneau even works! But...

1. I thought I might have an alignment issue, and have not taken the truck off road or even over a curb, but now I'm not sure it's not something bigger. I noticed that my wheel looks slightly off-centered, as others have reported, probably by 5ish degrees. When held straight, the truck will pull to the left, consistent with the wheel being off to the right when keeping the vehicle straight. What I noticed, though is that the gap on the driver side of the steering column, below the display, is large enough for my smallest fingertip to fit, but the opposite side is not. And when looked at closely, it looks like the column is slightly off center. Anyone else notice this/have this/willing to check if that's the case for theirs?

2. I can't quite tell if maybe my hood isn't somehow damaged or out of alignment. It looks to me as if the corners near the headlights are excessively curved in. I thought it might be the hood needed adjusted and pulled towards the front of the vehicle, but actually the hood edges closest to the windshield look perfectly aligned with the fender lines.

3. My charging door is a little out of perfect center/flush. It's not severe but its definitely noticeable. Anyone have experience with having it adjusted?

4. How long have people waited to get their full size spare that wasn't installed at delivery?

5. Anyone else got a weird little bump/pinch on their interior trim by a window?

6. My drivers seat trim on the drivers side is separating it seems. It doesn't look broken anywhere though. Anyone else?

7. And lastly...noises. Biggest issue is a recent clicking sound from under the truck when I push the pedal, and when I come off the pedal. My assumption is it has something to do with the motor reversing, but given it wasn't there to start, it's bugging me. And it's really annoying. I've also got a couple small rattles that have me worried only because the mileage is relatively low and it's summer. Anyone else feel like they're getting noises quickly?

Nothing service can't address I'm sure, but it'd be helpful to know what others' experiences have been so I have an idea what is reasonable to expect. View attachment 7695 View attachment 7692 View attachment 7693 View attachment 7694 View attachment 7695
View attachment 7694
View attachment 7693
View attachment 7692

I had a handful of minor trim misalignments, door misalignments, a squeaking noise, and other gremlins, and I made a few tickets with the service center and included pictures. It was a bit of a wait for them to call me in (about 3-5 weeks), but once I dropped off my R1T they fixed them ALL before the end of the day (I also had 2500 miles on the vehicle at the time). I wouldn’t hesitate to reach out to them and make a support ticket.

They also installed my spare while they had it in for service.
 

·
Registered
Joined
·
12 Posts
I've got the same charge door misalignment (it clips the surrounding trim slightly) and hood panel gap issues. I've also been waiting over two months for some sort of update to unfreeze the rear seat touchscreen (yes, it's in Unlocked mode lol) but that ticket remains open.

Service center here in Bellevue WA seems pretty overwhelmed with activity but they definitely work hard and are very courteous.
 

·
Registered
R1T LE
Joined
·
42 Posts
Bringing my questions to the experts, and I have a lot of them. Can I start by saying that I love the truck, am an unabashed lemming that would follow RJ over a cliff, and won't be getting rid of the truck anytime soon. Just don't tell them that please. After a bumpy start with a still-not-yet-really-understood issue with a BCM that vanished after I did a 100% charge (my idea, not theirs), it's been a smooth experience. My tonneau even works! But...

1. I thought I might have an alignment issue, and have not taken the truck off road or even over a curb, but now I'm not sure it's not something bigger. I noticed that my wheel looks slightly off-centered, as others have reported, probably by 5ish degrees. When held straight, the truck will pull to the left, consistent with the wheel being off to the right when keeping the vehicle straight. What I noticed, though is that the gap on the driver side of the steering column, below the display, is large enough for my smallest fingertip to fit, but the opposite side is not. And when looked at closely, it looks like the column is slightly off center. Anyone else notice this/have this/willing to check if that's the case for theirs?

2. I can't quite tell if maybe my hood isn't somehow damaged or out of alignment. It looks to me as if the corners near the headlights are excessively curved in. I thought it might be the hood needed adjusted and pulled towards the front of the vehicle, but actually the hood edges closest to the windshield look perfectly aligned with the fender lines.

3. My charging door is a little out of perfect center/flush. It's not severe but its definitely noticeable. Anyone have experience with having it adjusted?

4. How long have people waited to get their full size spare that wasn't installed at delivery?

5. Anyone else got a weird little bump/pinch on their interior trim by a window?

6. My drivers seat trim on the drivers side is separating it seems. It doesn't look broken anywhere though. Anyone else?

7. And lastly...noises. Biggest issue is a recent clicking sound from under the truck when I push the pedal, and when I come off the pedal. My assumption is it has something to do with the motor reversing, but given it wasn't there to start, it's bugging me. And it's really annoying. I've also got a couple small rattles that have me worried only because the mileage is relatively low and it's summer. Anyone else feel like they're getting noises quickly?

Nothing service can't address I'm sure, but it'd be helpful to know what others' experiences have been so I have an idea what is reasonable to expect. View attachment 7695 View attachment 7692 View attachment 7693 View attachment 7694 View attachment 7695
View attachment 7694
View attachment 7693
View attachment 7692
What's the last 6 digits of you VIN # ? I'm 003666 with less issues than yours.
 

·
Registered
R1T LE
Joined
·
42 Posts
I waited about a month and a half for the full size spare. Had it installed while at the SC for a windshield replacement. If not for that I probably would have waited longer.
Was that windshield replacement a warranty issue or did you have to pay for the repair due to damage ? Just curious what they charge since I heard the price is pretty high.
 

·
Registered
Joined
·
44 Posts
Was that windshield replacement a warranty issue or did you have to pay for the repair due to damage ? Just curious what they charge since I heard the price is pretty high.
Took a rock to the windshield so it was an insurance claim. Luckily deductible int too high. The windshield replacement itself was $1700 which, yes, is quite steep. Really hope this can come down over time.
 
1 - 15 of 15 Posts
Top